Updating Plugins

Due to constraints on our time, we do not always have our plugins available in the store immediately (much to our chagrin). However, because we use .Net to develop our plugins, in general you can modify the xml to have them load in the latest version (ie 2016).  This article will show you how to make those changes.

First of all, there are 3 locations where plugins may be stored. These have changed as Autodesk has changed their policies, so you may have to check each of these locations for the plugin.

  • C:\Users\%USERNAME%\AppData\Roaming\Autodesk\ApplicationPlugins
  • C:\Program Files\Autodesk\ApplicationPlugins
  • C:\ProgramData\Autodesk\ApplicationPlugins

The current installation directory for App Store plugins is: C:\ProgramData\Autodesk\ApplicationPlugins

Locate the plugin you wish to modify. In this case, we’ll look at the Selection list plugin.

2015-06-16_9-10-29

Inside the plugin folder is a file called PackageContents.xml. This file lets Autodesk products know how to load the plugin.

2015-06-16_9-12-17

You can open this in an xml or text editor and do a search for SeriesMax. Modifying the SeriesMax, or SeriesMin value will change the version the plugin loads into.

2015-06-16_9-05-03

Here are some notes on the xml format:

http://help.autodesk.com/view/ACD/2016/ENU/?guid=GUID-1591CA01-EF87-48CD-952B-772FE26037F1

Here is a table for the last few versions. We’ll try to keep this updated.

AutoCAD 2013 19.0
AutoCAD 2014 19.1
AutoCAD 2015 20.0
AutoCAD 2016 20.1
AutoCAD 2017 21.0